解决Ubuntu 9.04 下 PulseAudio声音故障

升级系统到Ubuntu 9.04之后,发现系统没声音了,pulseaudio和alsa都不可用,只有oss还能用。

参考了Ubuntu 8.04/8.10 系统无声、音频独占的解决方法解决了这个问题,只是按照文中给出的办法是把pulseaudio干掉,之用alsa,貌似照做一遍之后pulseaudio和alsa都恢复了正常。

做法如下

jim@jim-laptop:~$ sudo apt-get install alsa-oss libasound2 libasound2-plugins
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
libasound2 已经是最新的版本了。
libasound2-plugins 已经是最新的版本了。
下列【新】软件包将被安装:
alsa-oss
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。
需要下载 54.2kB 的软件包。
解压缩后会消耗掉 229kB 的额外空间。
获取:1 jaunty/universe alsa-oss 1.0.17-1 [54.2kB]
下载 54.2kB,耗时 2min 2s (442B/s)
选中了曾被取消选择的软件包 alsa-oss。
(正在读取数据库 ... 系统当前总共安装有 247714 个文件和目录。)
正在解压缩 alsa-oss (从 .../alsa-oss_1.0.17-1_i386.deb) ...
正在处理用于 man-db 的触发器...
正在设置 alsa-oss (1.0.17-1) ...
正在处理用于 libc6 的触发器...
ldconfig deferred processing now taking place

jim@jim-laptop:~$ cd /etc/X11
jim@jim-laptop:/etc/X11$ cd Xsession.d/
jim@jim-laptop:/etc/X11/Xsession.d$ ls
20x11-common_process-args                    60xdg-user-dirs-update
30x11-common_xresources                      65mesa-check-x86-64
40x11-common_xsessionrc                      70pulseaudio
50x11-common_determine-startup               75dbus_dbus-launch
52libcanberra-gtk-module_add-to-gtk-modules  80im-switch
55gnome-session_gnomerc                      90consolekit
60seahorse-plugins                           90x11-common_ssh-agent
60x11-common_localhost                       99x11-common_start
jim@jim-laptop:/etc/X11/Xsession.d$ sudo mv 70pulseaudio ~/
[sudo] password for jim:

jim@jim-laptop:/etc/X11/Xsession.d$ gconftool-2 -s -t bool /apps/gnome_settings_daemon/plugins/sound/active false

jim@jim-laptop:/etc/X11/Xsession.d$ asoundconf unset-pulseaudio

jim@jim-laptop:/etc/X11/Xsession.d$ sudo update-rc.d -f pulseaudio remove
Removing any system startup links for /etc/init.d/pulseaudio ...
/etc/rc1.d/K15pulseaudio
/etc/rc2.d/S50pulseaudio
/etc/rc3.d/S50pulseaudio
/etc/rc4.d/S50pulseaudio
/etc/rc5.d/S50pulseaudio

jim@jim-laptop:/etc/X11/Xsession.d$ asoundconf list
Names of available sound cards:
Intel
jim@jim-laptop:/etc/X11/Xsession.d$ asoundconf set-default-card Intel

jim@jim-laptop:/etc/X11/Xsession.d$ gedit ~/.bashrc
jim@jim-laptop:/etc/X11/Xsession.d$

在 ~/.bashrc文件中增加
export SDL_audiodriver=alsa
最后把音效里面的所有声音选项都换成pulseaudio,然后重启电脑,声音问题就解决了

图片 1

本文由js9905com金沙网站-金沙澳门手机版网址发布于计算机,转载请注明出处:解决Ubuntu 9.04 下 PulseAudio声音故障

您可能还会对下面的文章感兴趣: